602 status code with Directions API Route Matrix service

2 posts / 0 new
Last post
DeMiTeLi
602 status code with Directions API Route Matrix service

Hi averyone!

I have faced with the same status code when tried to retrieve route matrix. My application have a lot of such addresses that can't be processed by mapquest sevice. Below an example of one of the addresses.

My request is : http://mapquestapi.com/directions/v2/routematrix?ambiguities=ignore&unit...

And response :

{
  "allToAll": false,
  "distance": [
    0,
    0
  ],
  "time": [
    0,
    0
  ],
  "locations": [
    {
      "latLng": {
        "lng": 13.37699,
        "lat": 52.51607
      },
      "adminArea4": "",
      "adminArea5Type": "City",
      "adminArea4Type": "County",
      "adminArea5": "Berlin",
      "street": "Ebertstraße",
      "adminArea1": "DE",
      "adminArea3": "Berlin",
      "type": "s",
      "displayLatLng": {
        "lng": 13.37699,
        "lat": 52.51607
      },
      "linkId": 0,
      "postalCode": "10117",
      "sideOfStreet": "N",
      "dragPoint": false,
      "adminArea1Type": "Country",
      "geocodeQuality": "STREET",
      "geocodeQualityCode": "B1AAA",
      "adminArea3Type": "State"
    },
    {
      "latLng": {
        "lng": 8.07158,
        "lat": 50.62745
      },
      "adminArea4": "",
      "adminArea5Type": "City",
      "adminArea4Type": "County",
      "adminArea5": "Rennerod",
      "street": "Siegener Straße",
      "adminArea1": "DE",
      "adminArea3": "Rhineland-Palatinate",
      "type": "s",
      "displayLatLng": {
        "lng": 8.07158,
        "lat": 50.62745
      },
      "linkId": 0,
      "postalCode": "56477",
      "sideOfStreet": "N",
      "dragPoint": false,
      "adminArea1Type": "Country",
      "geocodeQuality": "STREET",
      "geocodeQualityCode": "B1AAA",
      "adminArea3Type": "State"
    }
  ],
  "manyToOne": false,
  "info": {
    "copyright": {
      "text": "© 2017 MapQuest, Inc.",
      "imageUrl": "http://api.mqcdn.com/res/mqlogo.gif",
      "imageAltText": "© 2017 MapQuest, Inc."
    },
    "statuscode": 602,
    "messages": [
      "Route matrix failed - unknown error in route computation"
    ]
  }
}

Another coordinates for which service can't calculate route matrix:

FROM | TO

"lng":13.37699,"lat":52.51607 | "lng":8.07158,"lat":50.62745

"lng":13.37699,"lat":52.51607 | "lng":7.59424,"lat":50.3819

"lng":13.37699,"lat":52.51607 | "lng":7.3702,"lat":50.64332

"lng":13.37699,"lat":52.51607 | "lng":7.60736,"lat":50.4153

"lng":13.37699,"lat":52.51607 | "lng":7.27781,"lat":50.35721

"lng":13.37699,"lat":52.51607 | "lng":9.47357,"lat":50.344825

"lng":13.37699,"lat":52.51607 | "lng":6.37283,"lat":47.816925

"lng":13.37699,"lat":52.51607 | "lng":6.95754,"lat":51.59949

"lng":13.37699,"lat":52.51607 | "lng":7.51022,"lat":50.40402

"lng":6.5907,"lat":51.49517 | "lng":6.15808,"lat":51.69038

"lng":13.37699,"lat":52.51607 | "lng":7.46081,"lat":50.12851

"lng":13.37699,"lat":52.51607 | "lng":7.63266,"lat":50.37302

"lng":13.37699,"lat":52.51607 | "lng":6.30413,"lat":50.2622

I guess that issue boud with "from" coordinates.

Have anybody faced with such kind of error or have any ideas what can be wrong with the reques?

Thanks for help!


MQBrianCoakley
Thanks for the information.
Thanks for the information. This has been forwarded on to the development team to assess.