GeoCoding Canadian Addresses now failing

6 posts / 0 new
Last post
munro.ross
GeoCoding Canadian Addresses now failing

We have a mature application that has suddenly lost its ability to geocode Canadian addresses.  Even when feeding addresses that have been correctly coded in the past, the results set suggests only US based possible matches.  If I escape without selecting from the match set, the map will drop the pin in the centre of the correct city, but nowhere near the address.  Anyone else having difficulty with Canadian addresses.  Appears to have just started today.


MQBrianCoakley
There were no updates to the
There were no updates to the geocoder today, Canadian or otherwise. Can you post a sample request that changed and doesn't show the address response that it used to?

munro.ross
We have a workaround.  Up

We have a workaround.  Up until now we have not been sending the country code for Canada, but getting correct results back.  We have tested adding country code into our request and are once again getting correct results back.  I know you indicate nothing changed, but our code base is stable (we contract out the programming, and have not changed production in any way).  I will have our programmer update our code and roll it into production ASAP to fix the issue.  


MQBrianCoakley
An update included in a
An update included in a security patch has been rolled back and the Canadian geocoder should be performing like it did before Tuesday. Sorry for the inconvenience.

munro.ross
Thank you

We can confirm that things are operating normally again.  We will have the workaround coded into our next production release to prevent recurrence.  We appreciate MapQuest's prompt attention to this!


MQBrianCoakley
That's good to know. Thanks
That's good to know. Thanks for confirming you're up and running again.